В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nazarzadorozhny
nazarzadorozhny
31.08.2020 03:23 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет
количество трёхзначных чисел, кратных 3. Программа получает на вход количество
чисел в последовательности, а затем сами числа. Программа должна вывести одно
число: количество трёхзначных чисел, кратных 3.

Показать ответ
Ответ:
fox2457667
fox2457667
03.09.2021 18:06
Не совсем понятно условие, но вот возможное решение в C++
#include <iostream>
#include <iomanip>
#include <ctime>
int main()
{
    using namespace std;

    cout << "Enter N: ";
    int N;
    cin >> N;

    int * A = new int[N];
    srand(time(0));
    for (int i = 0; i < N; ++i)
        A[i] = rand() % N + 1;

    for (int i = 0; i < N; ++i)
        cout << setw(4) << A[i];

    cout << "\nEnter K: ";
    int K;
    cin >> K;

    int SIZE = 0;
    for (int i = 0; i < N; ++i)
        if (A[i] <= K)
            ++SIZE;

    if (SIZE > 0)
    {
        int * A1 = new int[SIZE];
        int i1 = 0;
        for (int i = 0; i < N; ++i)
            if (A[i] <= K)
            {
                A1[i1] = A[i];
                ++i1;
            }
        for (int i1 = 0; i1 < SIZE; ++i1)
            cout << setw(4) << A1[i1];
        delete[] A1;
    }
    else
        cout << "No elements" << endl;
    delete[] A;
    cout << endl;
    return 0;
}
0,0(0 оценок)
Ответ:
sirushdarbinyap0aqdv
sirushdarbinyap0aqdv
23.05.2021 17:59
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const n = 10;
var a:array[1..n] of integer;
i,j:integer;
begin
// Заполним массив сл. числами
  for i:=1 to n do begin
    a[i]:=random(0,99); write(a[i]:4);
  end;
  writeln;
//сортировка массива по убыванию последней цифры.
  for i := 1 to n-1 do
    for j := 1 to n-i do
      if (a[j] mod 10) > (a[j+1]mod 10) then
      swap(a[j],a[j+1]);
  writeln('Отсортированный массив : ');
  for i:=1 to n do write(a[i]:4);   
end.

Тестовое решение:
  14  60  69   6  10  77  66  67  44  84
Отсортированный массив :
  60  10  14  44  84   6  66  77  67  69
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота