В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
muradir1102
muradir1102
26.04.2020 01:36 •  Информатика

Напишите программу которая в последовательности целых чисел определяет максимальное из чисел

Показать ответ
Ответ:
revon
revon
27.09.2020 21:09
Вот тебе простой вариант ришение задачи (коментар=пояснение)

PascalВыделить код

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16  program prg;  uses crt;  var  rez,chislo,min,max:integer;  begin  Write('Enter number =  ');readln(chislo);                 //zanosim 1 chislo  max:=chislo;                                              //v max ta min  min:=chislo;                                              //chtobu potom mu soukb sravnivat s drugimi chislamu  while (chislo<>0) do                                      //zapuskaem zikl poka mu ne napishem 0  begin   if (chislo>max)then max:=chislo;                         //sravnivaem s max   if (chislo<min) then min:=chislo;                        //sravnivaem s min   readln(chislo);                                          //snova pihem chislo   end;   rez:=(max-min);                                          //nahodim raznizy   writeln('max(',max,') - min(',min,') = ',rez);           //otvet end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота