Напишите программу, которая в последовательности целых чисел определяет сумму чётных чисел, принадлежащих интервалу (15, 190) или сообщает, что таких чисел нет (выводит "net"). программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 -- признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму чётных чисел, принадлежащих интервалу (15, 190) или вывести "net", если таких чисел нет. пример работы программы: вход: 5 15 25 48 180 196 0 выход: 228 (48+180) язык паскаль
begin
readln(a);
while a<>0 do begin
readln(a);
if (a >15) and (a<190) and (a mod 2=0) then
s:=s+a;
end;
writeln(s);
end.