В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
pirlikserge05
pirlikserge05
29.09.2020 08:30 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет сумму положительных чисел, кратных 5. программа получает на вход целые числа, кол-во введенных чисел неизвестно, последовательность чисел заканчивается числом 0. кол-во чисел не превышает 1000. введенные числа по модулю не превышают 30 000. программа должна вывести одно число: сумму положительных чисел, кратных 5. пример работы программы: входные данные : -25; 45; 20; 1; 0. выходные данные: 65. p.s. учительница сказала найти сумму, кол-во,,min.

Показать ответ
Ответ:
aizhan05
aizhan05
07.10.2020 19:02
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (s,k,p,mx,mn):=(0,0,BigInteger(1),-30001,30001);
  ReadSeqIntegerWhile(t->t<>0).Where(t->(t>0) and (t mod 5=0))
    .Foreach(t->begin s+=t; k+=1; p*=t; mx:=Max(mx,t); mn:=Min(mn,t) end);
  Writeln('S=',s,', K=',k,', П=',p,', min=',mn,', max=',mx)
end.

Пример
9095 -15199 5068 5310 2534 1136 11454 -17910 3480 -23949 24356 -5077 27301 -25057 -5789 24995 -16013 -5246 -5168 16256 17565 -24551 -229 22412 -3274 20445 3399 -11620 -21875 -18607 0
S=80890, K=6, П=1508567956180663412250000, min=3480, max=24995

Напишите программу, которая в последовательности целых чисел определяет сумму положительных чисел, к
0,0(0 оценок)
Ответ:
AndaDi
AndaDi
07.10.2020 19:02
Решение на Python 3.Среда разработки IDLE 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота