В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Vikzza
Vikzza
29.11.2022 06:29 •  Информатика

Напишите программу, которая в последовательности целых чисел определяет сумму трёхзначных чисел, не оканчивающихся на 2. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0. Количество чисел не превышает 1000. Введённые числа не превышают 30000.

Показать ответ
Ответ:
secret213p089no
secret213p089no
13.10.2020 21:38

Язык программирования Python

print("Введите последовательность чисел через пробел")

A = input()

A = A.split()

N = 0

OK = True

S = 0

for i in range(0, len(A), 1):

   for d in A[i]:

       N += 1

       if N == 3 and d == "2":

           OK = False

   if N == 3 and OK:

       S += int(A[i])

   N = 0

   OK = True

print(S)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота