В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
leravalera228
leravalera228
01.03.2022 00:14 •  Информатика

напишите программу которая в последовательности чисел заканчивающуюся нулем определяет среднее арифметическое четных чисел кратных 3 и трехзначных, ПИТОН

Показать ответ
Ответ:
Викитирон
Викитирон
09.03.2021 17:05

summ = 0

count = 0

while 1:

   a = int(input())

   if a == 0:

       break

   elif len(str(abs(a))) == 3 and a % 2 == 0 and a % 3 == 0:

       summ += a

       count +=1

print(summ/count)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота