В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Aliya205
Aliya205
30.11.2022 11:49 •  Информатика

Напишите программу, которая в последовательности натуральных чисел находит количество двузначных чисел, кратных 4, или сообщает, что таких чисел нет. Программа получает на вход
натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается
числом 0 (0 – признак окончания ввода, не является членом последовательности). Программа
должна вывести количество чисел, удовлетворяющих условию, или вывести NO, если таких
чисел в последовательности нет

Показать ответ
Ответ:
gimnastikgirla
gimnastikgirla
15.10.2020 13:01

// PascalABC.NET

begin

 var k := ReadSeqIntegerWhile(p -> p <> 0)

   .Count(p -> (p mod 4 = 0) and (p in Range(10,99)));

 if k = 0 then

   Write('NO')

 else

   Write(k)  

end.

0,0(0 оценок)
Ответ:
Брат111111111
Брат111111111
15.10.2020 13:01
begin var n := ReadSeqIntegerWhile(x->x<>0).Count(x->(x mod 4 = 0) and (x in 10..99)); Write(n=0?'NO':n.ToString) end.

Пример работы:


Напишите программу, которая в последовательности натуральных чисел находит количество двузначных чис
Напишите программу, которая в последовательности натуральных чисел находит количество двузначных чис
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота