.Напишите программу, которая в последовательности натуральных чисел вычисляет сумму чисел кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно последовательность чисел заканчивается числом 0 (0- признак окончания ввода не входит в последовательность)
Решал на паскале.
Первая:
var i:integer; s:string; a:array[1..3] of integer; t.q,z: boolean;
begin
readln(i); q:=false; t:=false;
a[1]:=i mod 10;
a[2]:=i div 10 mod 10;
a[3]:=i div 10 div 10;
for i:=1 to 3 do
begin
if a[i]=4 then
q:=true;
if (a[i]=7) and (q=true) then t:=true;
if a[i]=7 then z:=true;
end;
if t=true then writeln('Vhodyat oba) else if (q=true) and (z=false) then writeln('Vhodit 4') else if (q=false) and (z=true) then writeln('Vhodut 7');
readln;
end.
Вторая:
var a,b,c,min:integer;
begin
min:=32000;
readln(a,b,c);
if a<min then min:=a; if b<min then min:=b; if c<min then min:=c;
writeln ('Minimalnoe - ',min);
readln;
end.
Третья:
var a,b,c:integer; x,y,d:real;
begin
readln(a,b,c);
d:=b*b-(4*a*c);
if d=0 then
begin
x:=(-b/2*a);
writeln('One root: ',x:0:0);
end;
if d>0 then
begin
x:=(-b+sqrt(d))/2*a;
y:=(-b-sqrt(d))/2*a;
if y>x then
writeln('Two roots: ',x:0:0,' ',y:0:0) else writeln('Two roots: ',y:0:0,' ',x:0:0);
end;
if d<0 then writeln('No roots');
readln;
end.:
1)
#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;
void print(int*);
int main()
{
int a[10];
srand(time(0));
//Заполняем случайными числами от 1 до 10
for(int i = 0; i < 10; i++)
{
a[i] = rand() % 10 + 1;
}
print(a);
//Меняем местами
int temp;
for(int i = 0; i <= 10; i += 2)
{
temp = a[i];
a[i] = a[i + 1];
a[i + 1] = temp;
}
print(a);
return 0;
}
void print(int *a)
{
for(int i = 0; i < 10; i++)
{
cout << a[i] << ' ';
}
cout << endl;
}
2)
#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;
void print(int*);
int main()
{
int a[10];
srand(time(0));
//Заполняем случайными числами от 0 до 10
for(int i = 0; i < 10; i++)
{
a[i] = rand() % 11;
}
print(a);
//Находим индекс максимального элемента
int largest = 0;
for(int i = 0; i < 10; i++)
{
if(a[largest] < a[i])
{
largest = i;
}
}
//Меняем местами
int temp = a[0];
a[0] = a[largest];
a[largest] = temp;
print(a);
return 0;
}
void print(int *a)
{
for(int i = 0; i < 10; i++)
{
cout << a[i] << ' ';
}
cout << endl;
}