В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел,кратных 8. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0-признак окончания ввода, не входит в последовательность.программа должна вывести одно число: сумму всех двузначных чисел, кратных 8.

Показать ответ
Ответ:
vitcke1
vitcke1
06.10.2020 11:32
Program hhh54;
var i,x,s:longint;
begin
  read (x);
  s:=0;
  while x <> 0 do
    begin
      if (x>9) and (x<100) and (x mod 8 = 0) then s:=s+x;
      read (x);
    end;
  write (s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота