В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
аграил9
аграил9
08.04.2022 18:47 •  Информатика

Напишите программу которая в зависимости от введенной оценки в диапазоне от 1 до 12 выводит уровень к которому она относится c++​

Показать ответ
Ответ:
evamakarova20
evamakarova20
09.10.2020 22:07

#include <iostream>

using namespace std;

int main() {

int n;

cin>>n;

switch (n)

{

case 1:

case 2:

case 3:

 cout<<"Неудовлетворительно";

 break;

case 4:

case 5:

case 6:

 cout<<"Удовлетворительно";

 break;

case 7:

case 8:

case 9:

 cout<<"Хорошо";

 break;

case 10:

case 11:

case 12:

 cout<<"Отлично";

 break;

default: cout<<"Ошибка ввода";

}

return 0;

}

Вот сам макет программы. Если нужны дугие уровни оценок - можно просто заменить выводимый текст на требуемый.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота