В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
annapar2017p00w0y
annapar2017p00w0y
21.09.2021 15:41 •  Информатика

Напишите программу, которая во введенной с клавиатуры строке заменяет все цифры на латинские буквы по следующему правилу : 0-a 1-b 2-c 3-d 4-e 5-f 6g 7-h 8-i 9-j

Показать ответ
Ответ:
Daniil3037
Daniil3037
10.06.2022 19:02

#include <iostream>

using namespace std;

int main()

{

   int line, column;

   cout << "Введите количество строк и столбцов через пробел: ";

   cin >> line >> column;

   int array[50][50] = {};

   cout << "Введите элементы двумерного массива: \n";

   for (int i = 0; i < line; i++ )

   {

       for (int j = 0; j < column; j++)

       {

           cin >> array[i][j];

       }

       cout << endl;

   }

   int amount = 0;

   int line_index;

   cout << "Введите индекс строки массива: ";

   cin >> line_index;

   for (int j = 0; j < column; j++)

   {

       int i = line_index;

       amount += array[i][j];

   }

   if (amount % 10 == 0)

   {

       cout << "YES";

   }

   else

   {

       cout << "NO";

   }

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int line, column;  // Создание целочисленных переменных, отвечающих за количество строк и столбцов в двумерном массиве

   cout << "Введите количество строк и столбцов через пробел: ";  // Вывод сообщения в консоль

   cin >> line >> column;  // Ввод количества строк и столбцов с клавиатуры

   int array[50][50] = {};  // Создание целочисленного массива размером 50х50

   cout << "Введите элементы двумерного массива: \n";  // Вывод сообщения в консоль

   for (int i = 0; i < line; i++ )  // Ввод элементов массива

   {  // Ввод элементов массива

       for (int j = 0; j < column; j++)  // Ввод элементов массива

       {  // Ввод элементов массива

           cin >> array[i][j];  // Ввод элементов массива

       }  // Ввод элементов массива

       cout << endl;  // Ввод элементов массива

   }  // Ввод элементов массива

   int amount = 0;  // Создание целочисленной переменной, хранящей сумму нужной строки

   int line_index;  // Переменная, хранящая индекс нужной строки

   cout << "Введите индекс строки массива: ";  // Вывод сообщения в консоль

   cin >> line_index;  // Ввод индекса нужной строки с клавиатуры

   for (int j = 0; j < column; j++)  // Находим все элементы нужной строки

   {

       int i = line_index;  // Нужна сумма определенной строки ⇒ значение переменной i будет постоянным

       amount += array[i][j];  // Переменная, хранящая сумму элементов нужной строки, суммируется с элементами строки

   }

   if (amount % 10 == 0)  // Если последняя цифра суммы = 0

   {

       cout << "YES";  // Выводим "YES"

   }

   else  // Иначе

   {

       cout << "NO";  // Выводим "NO"

   }

}

0,0(0 оценок)
Ответ:
sonka247
sonka247
09.05.2021 02:41

#include <iostream>

using namespace std;

int main()

{

   int line, column;

   cout << "Введите количество строк и столбцов через пробел: ";

   cin >> line >> column;

   int array[50][50] = {};

   cout << "Введите элементы двумерного массива: \n";

   for (int i = 0; i < line; i++ )

   {

       for (int j = 0; j < column; j++)

       {

           cin >> array[i][j];

       }

   }

   int max = array[0][1];

   int line_number = 1;

   for (int i = 0; i < line; i++)

   {

       int j = 1;

       if (max < array[i][j])

       {

           max = array[i][j];

           line_number = i + 1;

       }

   }

   cout << line_number;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

  int line, column;  // Создание целочисленных переменных, отвечающих за количество строк и столбцов в двумерном массиве

  cout << "Введите количество строк и столбцов через пробел: ";  // Вывод сообщения в консоль

  cin >> line >> column;  // Ввод количества строк и столбцов с клавиатуры

  int array[50][50] = {};  // Создание целочисленного массива размером 50х50

  cout << "Введите элементы двумерного массива: \n";  // Вывод сообщения в консоль

  for (int i = 0; i < line; i++ )  // Цикл для ввода элементов массива

  {

      for (int j = 0; j < column; j++)  // Цикл для ввода элементов массива

      {

          cin >> array[i][j];  // Ввод элементов массива

      }

  }

   int max = array[0][1];  // Присваиваем переменной, хранящей максимум, значение массива в 0 строке и 1 столбце

   int line_number = 1;  // Переменная, хранящая номер строки

   for (int i = 0; i < line; i++)  // Цикл для прогона значений 2-го столбца

   {

       int j = 1;  // // Нужны значения определенного столбца ⇒ значение переменной j будет постоянным

       if (max < array[i][j])  // Если значение переменной max < значения массива i строки и j столбца

       {

           max = array[i][j];  // Значение переменной max = значению массива i строки и j столбца

           line_number = i + 1;  // Номер строки = индекс строки + 1 (т. к. индексация начинается с нуля)

       }

   }

   cout << line_number;  // Вывод ответа

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота