В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ThePud
ThePud
23.01.2022 18:00 •  Информатика

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. (c++)

Показать ответ
Ответ:
olgastavovaya1
olgastavovaya1
02.07.2020 20:22
#include <iostream>

int main(){
int a, b, i, c = 0, check = 0;

std::cout << "Введите певое значение:";
std::cin >> a;

std::cout << "Введите второе значение:";
std::cin >> b;

if(a < 0){
a*=-1;
check = 1;}

for(i = 0; i < a; i++)
if(check = 0)
c += b;
else
c -= b;
std::cout << c << " ";
std::cin >> b;

return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота