В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
2005Киса
2005Киса
11.12.2022 21:36 •  Информатика

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.(программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части.) совсем не получается решить ,

Показать ответ
Ответ:
vikaadvova
vikaadvova
02.10.2020 10:25
Program rast;
var x, y, l: real;
begin
  writeln('введите две координаты');
  readln(x, y);
  l:=sqrt(sqr(x)+sqr(y));
  writeln('расстояние ', l:3:2);
end.
0,0(0 оценок)
Ответ:
BamakoProfile
BamakoProfile
02.10.2020 10:25
1.{1.Напишите программу, которая вводит два вещественных числа, x и y , и вычисляет значение x^y .(Нужно вывести одно значение – x^y – с тремя знаками в дробной части.)}
  var x,y,k:real;
begin
 readln(x,y);
 k:=exp(y*ln(x));
 writeln(k:3:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота