В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
djasiclol
djasiclol
14.05.2023 05:08 •  Информатика

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр. Входные данные
Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр. Числа разделяются пробелами.

Показать ответ
Ответ:
Lizzzzxff
Lizzzzxff
12.02.2021 21:48

program z1;

var a,b,i,c,k:integer;

begin

read (a, b);

for i:=a to b do

begin

c:=i;

if c mod 10 = 0 then k:=1 else k:=0;

while (c > 0) and (k = 0) do

begin

if i mod (c mod 10) <> 0 then k:=1;

c:=c div 10;

if (c>0) and (c mod 10 = 0) then k:=1    

end;

if k = 0 then write (i,'  ')

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота