В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

напишите программу, которая вводит с клавиатуры 2 набора чисел в диапазоне 10..99 и проверяет, равны ли эти наборы.

Показать ответ
Ответ:
tagirok4525
tagirok4525
18.10.2022 09:37

#include <stdio.h>

#include <stdlib.h>

#include<time.h>

#include<malloc.h>

void matrix(void) {

setlocale(0,".1251");

 

unsigned int i,

             j;

long min,

     max;

printf("Введите количество строк матрицы:\n");

scanf("%u",&i);

printf("Введите количество столбцов матрицы:\n");

scanf("%u",&j);

printf("Введите минимум чисел:\n");

scanf("%li",&min);

printf("Введите максимум чисел:\n");

scanf("%li",&max);

srand(time(NULL));

long *mas = (long*)malloc(sizeof(long)*i*j);

printf("Ваш массив:\n");

for(unsigned int ti=0;ti<i;ti++){

 for(unsigned int tj=0;tj<j;tj++){

  mas[ti*j+tj] = rand()%(max-min+1)+min;

  printf("%li \t",mas[ti*j+tj]);

 }

 printf("\n");

}

printf("Елементы под побочной диагональю(лишние заменены на символ *):\n");

for(unsigned int ti=0;ti<i;ti++){

 for(unsigned int tj=0;tj<j;tj++){

  if(ti>j-tj-1) printf("%li \t",mas[ti*j+tj]);

  else printf("* \t");

 }

 printf("\n");

}

free(mas);

 

}

int main(int argc, char *argv[]) {

matrix();

return 0;

}

0,0(0 оценок)
Ответ:
наташа979
наташа979
04.05.2023 10:39

const

 n=3;m=4;

var

 a:array [1..n+1,1..m] of integer;

 i,j:integer;

begin

 for i:=1 to n do

   begin

     for j:=1 to m do

       begin

         readln(a[i,j]);

         if a[i,j]>0 then

           inc(a[n+1,j]);

       end;

     writeln;

   end;

 for i:=1 to n+1 do

   begin

     for j:=1 to m do

       write(a[i,j]:4);

     if i<>n then

       writeln

         else  

           begin

             writeln;

             writeln('Счётчик:');

           end;

   end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота