В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
моюр
моюр
11.01.2021 13:00 •  Информатика

Напишите программу, которая вводит с клавиатуры дынные о n лицах (n меньше либо равно 50) и выводит на экран фамилии и имена тех, кто родилсяв день z месяца.

Показать ответ
Ответ:
unknown38
unknown38
23.05.2020 22:20

type

person=record

fam:string;

imya:string;

day:integer;

end;

var

a:array[1..50] of person;

i,n,z:integer;

begin

write('n=');readln(n);

for i:=1 to n do

begin

write('fam-');readln(a[i].fam);

write('imya-');readln(a[i].imya);

write('day-');readln(a[i].day);

end;

write('z-');readln(z);

for i:=1 to n do

if a[i].day=z then writeln (a[i].fam, ' ',a[i].imya);

readln;

end.

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота