В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
SYSTEMCORE
SYSTEMCORE
22.11.2022 14:05 •  Информатика

Напишите программу которая вводит с клавиатуры натуральное число n и выводит на экран n первых элементов последовательности: 1, 3, 7, 15, 31, 63, (4 )

Показать ответ
Ответ:
leshakonovalov2
leshakonovalov2
03.07.2020 20:50

Каждое число в последовательности увеличивается на 2 в степени i - 1

где i это порядковый номер числа в последовательности

program raf105;

var

 x,n,i: integer;

begin

 readln(n);

 for i:=1 to n do

 begin

   x:= x + round(power(2,i-1));

   write(x,' ');

 end;

end.

PascalABC
0,0(0 оценок)
Ответ:
NaStYтуут
NaStYтуут
03.07.2020 20:50

var

k,i,a:Integer;

begin

a:=1;

readln(k);

for i:=1 to k do begin

write(a,' ');

a:=a+a+1;

end;

end.

Это паскаль

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота