В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
neznaika1112222
neznaika1112222
17.11.2021 19:38 •  Информатика

Напишите программу, которая вводит с клавиатуры три числа, и находит их сумму и произведение. (на языке Паскаль)​

Показать ответ
Ответ:
rusnazasly
rusnazasly
29.01.2021 19:30

var n, sum, mult: integer;

begin

write('Enter number: ');

readln(n);

sum := 0;

mult := 1;

while n > 0 do begin

sum := sum + n mod 10;

mult := mult * (n mod 10);

n := n div 10

end;

writeln('Sum of digits = ', sum);

writeln('Multiplication of digits = ', mult);

readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота