В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Артем15227897
Артем15227897
08.01.2020 04:09 •  Информатика

Напишите программу, которая вычисляет периметр треугольника (P), если длины его сторон равны a,b,c. Сделать несколько запусков программы при a=5, b=10, c=15; при a=5.5, b=6.2, c=7.07 Чтобы было все 4 шага

Показать ответ
Ответ:
Влад880035355
Влад880035355
24.10.2022 03:47
Решение задачи 1 в файле
Задача 2 если в классе 2 ученика, то после обмена будет 2 фотографии 2*(2-1)=2
               если в классе 3 ученика, то всего будет 6 фотографий: 3*(3-1)=6
                                       4 ученика                        12 фотографий:4*(4-1)=12
                                       х учеников                 по условию 600:  х*(х-1)=600
откуда x^2-x-600=0  дискриминант 2401 х1=-24(не подходит)
                                                             х2=25 ответ 25
По задаче 3 нет данных
0,0(0 оценок)
Ответ:
Максим111136322
Максим111136322
19.06.2021 13:05
Const
  nn=100; { максимальное значение n }
var
  i,n,k,s:integer;
  a:array[1..nn] of integer;
begin
  Write('Укажите натуральное число n: '); Read(n);
  Randomize;
  k:=0; s:=0;
  Writeln('Сформированная последовательность');
  for i:=1 to n do begin
    a[i]:=Random(99)+1; { случайное число на интервале [1;99] }
    Write(a[i]:3);
    if (a[i] mod 5=0) and (a[i] mod 7 <>0) then
      begin Inc(k); s:=s+a[i] end;
  end;
  Writeln;
  Writeln('Количество чисел, кратных пяти: ',k);
  Writeln('их сумма равна ',s)
end.

Тестовое решение:
Укажите натуральное число n: 39
Сформированная последовательность
 15 83 69 64 56 50 13 70 55 40 22 82 45 67 31 36 16 52 67 44 63 23 52 62 89 33 40 32 17 14 98 15  5 58 46 68 57 72 90
Количество чисел, кратных пяти: 9
их сумма равна 355
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота