В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Andrey346563545
Andrey346563545
01.06.2020 16:27 •  Информатика

Напишите программу, которая вычисляет сумму элементов последовательности целых чисел, поданных не её вход. Ввод заканчивается числом 0.

Показать ответ
Ответ:
zizizineb99
zizizineb99
23.02.2021 01:40

a = 1

A = []

while a != 0:

a = int(input())

A.append(a)

A.pop()

print(sum(A))

Объяснение:

0,0(0 оценок)
Ответ:
gilkatay1
gilkatay1
23.02.2021 01:40

def func(A):

 summ = 0

 a = int(input())

 if a != 0:

   A.append(a)

   return(func(A))

 else:

   for i in A:

     summ += i

 return summ

A =[]

print(func(A))

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота