В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
2003veronika07
2003veronika07
17.05.2021 17:39 •  Информатика

Напишите программу, которая вычисляет сумму квадратов чисел от А до В (A Sample Input:
5
10
Sample Output:
355
Напишит

Показать ответ
Ответ:
viktoska87
viktoska87
11.04.2020 13:17
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Ответ:
Emmaasakura
Emmaasakura
25.12.2021 02:14
Const l = 5;
var
a: array[1..l] of integer;
d: array[1..l] of real;
i, otr, k, m: integer;
begin
otr:=0; k:=0; m:=0;
//считаем массив а
for i:=1 to l do
  begin
    readln(a[i]);
    //если ввели положительное число,увеличим перем. otr на 1
    if a[i] < 0 then
      inc(otr);
    //если ввели отрицательное число,увеличим перем. k на 1
    //и к переменной m прибавим элемент
    if a[i] > 0 then
      begin
        inc(k);
        inc(m, a[i]);
      end;
  end;
//заполним массив d
for i:=1 to l do
  //если индекс четный, присвоим элементу otr
  //иначе присвоим среднее арифметическое
  if i mod 2 = 0 then
    d[i] := otr
  else
    d[i] := m/k;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота