В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
MaryWintlstone
MaryWintlstone
07.04.2020 00:59 •  Информатика

Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до 10. (please help me bro ) (i give lot points)

Показать ответ
Ответ:
чек7
чек7
15.06.2022 04:26
Объяснение:

1)Число точно больше 100, чтобы L было 3.

2)Какие бы числа мы не ставили на позициях единиц и десятков, результата они никакого не дадут, тк отрезаются командой div

3)Ближайшее необходимое число: 500

Дописал программу, чтобы проверить. Она выводит количество подходящих комбинаций при вводе всех чисел от 1 до 500.

var

x, L, M,count,i: integer;

begin

count:=0;

for i:=1 to 500 do

begin

x:=i; L := 0;M := 0;

while x > 0 do

begin

L := L + 1; x := x div 10;

if L mod 2 = 0 then

M := M + (x mod 10);

end;

//write(L,' ');write(M);

if (L=3) and (M=5) then inc(count);

end;

writeln(count);

end.
0,0(0 оценок)
Ответ:
Ксюшка221
Ксюшка221
10.10.2022 18:36

5 байт

Определим мощность алфавита для кодирования личного кода, по условию это 9 букв и 9 цифр,  то есть

N= 9+9 = 18 , один символ в таком случае кодируется: 5 битами (2⁵=32), т.к. 4 бит недостаточно для кодирования 18 символов ( 2⁴=16)

Всего символов в коде: k=12, значит информационный объем кода: 12*5= 60 бит. Минимальное число байт ( число кратное 8) = 8 байт

Определим объем информации для номера группы:

N=11 ⇒ i= 4 бит, минимальное число байт = 1 байт

Пропуск содержит 14 байт информации. значит объем  памяти необходимый для хранения дополнительных сведений=

14-8-1= 5 байт

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота