В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
IlyaPikarychev
IlyaPikarychev
28.04.2022 12:21 •  Информатика

Напишите программу, которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются только знаки «+» или «–»). Выражение вводится как символьная строка, все числа целые.Информатика 10 класс, Паскаль тема «Символьные строки»
Пример:
Введите выражение:
12-3+45
ответ: 54​

Показать ответ
Ответ:
Эмиль08072013
Эмиль08072013
02.08.2020 14:50
#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>

struct StudentData
{
    std::string name;
    std::string surname;
    int math;
    int phys;
    int comp_science;
};

bool
comp(const StudentData &a, const StudentData &b)
{
    int tmp1 = a.math + a.phys + a.comp_science;
    int tmp2 = b.math + b.phys + b.comp_science;
    return tmp1 > tmp2 ? true : false;
}

int
main(void)
{
    int n;
    std::cin >> n;
    std::vector< StudentData > data(n);
    for (int i = 0; i < n; i++) {
        std::cin >> data[i].name >> data[i].surname;
        std::cin >> data[i].math >> data[i].phys >> data[i].comp_science;
    }
    std::sort(data.begin(), data.end(), comp);
    for (int i = 0; i < n; i++) {
        std::cout << data[i].name << " " << data[i].surname << std::endl;
    }
    return 0;
}
0,0(0 оценок)
Ответ:
yannashipunova
yannashipunova
22.05.2022 14:19

3. CREATE TABLE

нужны имя полей и тип их данных, например уникальный ID это id = PRIMARY KEY

текст = text , не пустой текст = TEXT NOT NULL ,

числа = REAL,INT время = DATE и т.д

6. SELECT, FROM, GROUP BY, WHERE, ORDER BY, HAVING

7. SELECT - указывает , что извлекать из таблицы, так же может содержать агрегирующие функции и функции времени такие как EXTRACT, DATE_TRUNC

8. FROM - указывает из какой таблицы извлекать, так же можно указать подзапрос

9. WHERE - указывает какие условия нужны для извлечения , которые указаны в SELECT, не может сравнивать агрегирующие функции , для этого есть HAVING, также может содержать подзапрос

10. GROUP BY - групирует по .., HAVING - то же самое , что WHERE , только для агрегирующих функций

11. ORDER BY - использует методы ASC(по возрастанию значений) пример - имя_поле ASC, или DESC(по убыванию значений) - имя_поля DESC

Объяснение:

Будут вопросы напиши в коменты(

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота