В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
12VikaSmirnova34
12VikaSmirnova34
23.08.2022 10:04 •  Информатика

Напишите программу, которая выводит день недели, если ввести число этого месяца, этого года

Показать ответ
Ответ:
спасибо84
спасибо84
13.01.2022 12:14

Textcolor, Window, Textbackground в Pascal.

Текст, который мы выводим на экран с процедуры Writeln или с оператора Write можно изменять. Процедура Textcolor используется для изменения цвета выводимого текста. Процедура Textbackground изменяет цвет фона, на котором выводится ...

Использование program, begin…end, write, readln, Uses Crt, Clrscr.

В этом уроке мы напишем самую простую программу, состоящую всего из пяти строк. Эта программа будет выводить сообщение на экран. Для написания программы нам необходимо знать как работают операторы Write, Readln, а также понять для чего нужны ...

Функции LENGTH и CONCAT.

Функция Length возвращает в качестве значения длину строки. Например, если в строковой переменной «stroka» записано слово «Pascal», то Length(stroka) будет равно 6. Эта операция аналогична операции Ord(stroka[0]), которую мы разбирали в 1-м уроке. ...

Циклы и массивы

0,0(0 оценок)
Ответ:
olesyaprk
olesyaprk
24.12.2021 14:36

program ExampleN;

uses Math;   // объявление математических функций для вашей версии паскаля

var

 a, b, d, s, y1, y2, x: Double;

begin

 Write ('Введете границы отрезка: ');

 ReadLn (a, b);

 s := 0;

 d := (b - a) / 10;             // длина 1/10 отрезка

 x := a + d / 2;                // начальное значение Х = левая граница + половина отрезка (середина основания)

 while x < b do begin           // цикл по всей длине отрезка

   y1 := Sqr (x);

   y2 := 5 + x / 2;

   s := s + Abs (y1 - y2) * d;  // расчет площади прямоугольника и суммирование

   x := x + d;                  // увеличение Х на 1/10 отрезка

 end;

 WriteLn ('Площадь = ', s :20 :10);

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота