Напишите программу, которая выводит на экран максимальное из четырех целых чисел, введенных с клавиатуры. Используйте для написания программы словесный алгоритм.
Прежде чем писать программу, необходимо по условию задачи определить, какие данные у нас будут входными (то есть даны и будут вводиться с клавиатуры), а какие данные будут выходными (то есть представлять результат и будут выводиться на экран в качестве ответа)
В нашей задаче
ВХОДНЫЕ ДАННЫЕ: четыре целых числа через пробел
ВЫХОДНЫЕ ДАННЫЕ: одно число, максимальное из введенных
Запрещенные операторы: else;and;or;not
ПИТОН! ЗАРАНЕЕ
#include <iostream>
#include <windows.h>
#include <math.h>
using namespace std;
int main ()
{
double a,b;
cout << "enter a: ";
cin >> a;
cout << "enter b: ";
cin >> b;
if( (a-b)*(a+b) > fabs(a*a-2*a*b+b*b))
{
cout << " bolshe raznost kvadratov";
return 0;
}
else
{
cout << " bolshe modul kvadrata raznosti";
return 0;
}
return 0;
}
#include <iostream>
#include <windows.h>
#include <math.h>
using namespace std;
int main ()
{
double a,b;
cout << "enter a: ";
cin >> a;
cout << "enter b: ";
cin >> b;
if( (a-b)*(a+b) > fabs(a*a-2*a*b+b*b))
{
cout << " bolshe raznost kvadratov";
return 0;
}
else
{
cout << " bolshe modul kvadrata raznosti";
return 0;
}
return 0;
}