В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
SOSmi
SOSmi
16.02.2020 01:33 •  Информатика

Напишите программу, которая выводит на экран N случайных целых чисел и находит их сумму, произведение, среднее арифметическое всех чисел и значение квадратного корня из суммы всех чисел. (N вводит пользователь) используете только цикл с параметром

Показать ответ
Ответ:
гузаля
гузаля
11.05.2022 12:05
Сначала массив Dat заполняется числами 2, 8, 6, ..., 7.
Затем производится поиск максимума среди Dat[1], Dat[8..12] (стандартный алгоритм: в m хранится текущий максимум, в month – номер месяца, в котором этот максимум впервые реализуется. Перед циклом m = Dat[1], month = 1, в цикле если элемент массива больше текущего максимума, то текущий максимум и номер месяца перезаписываются).
Наконец, выводится month – номер месяца, в котором впервые количество детских праздников достигает максимума.

Максимальное значение равно 8, впервые встречается среди Dat[1], Dat[8..12] в Dat[9].

ответ: 9.  
0,0(0 оценок)
Ответ:
Ulyana2006mizik5B
Ulyana2006mizik5B
19.12.2022 00:50
//Pascal
var
  A: array[1..10] of integer;
  i, Count: byte;
  sum: integer;
begin
  randomize;
  writeln('Сгенерированный массив');
  for i := 1 to 10 do
  begin
    A[i] := random(8)-3;
    if A[i] < 0 then
      sum := sum + A[i];
    write(A[i],' ');
  end;
  writeln;
  writeln('Сумма отрицательных элементов = ', sum);
  writeln;
  writeln('Измененный массив');
  for i := 1 to 10 do
  begin
    if A[i] >= 0 then
    begin
      A[i] := 0;
      Count := Count + 1;
     end;
    write(A[i], ' ');
  end;
  writeln;
  writeln('Количество нулевых элементов = ', Count);
end.

Массив из 10 элементов заполнить случайными числами от - 3 до 4 включительно. найти сумму отрицатель
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота