В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Oхxxymiron
Oхxxymiron
24.01.2023 07:39 •  Информатика

Напишите программу, которая выводит на экран все цифры числа, начиная с первой.входные данныевходная строка содержит натуральное число n .выходные данныепрограмма должна вывести все цифры введённого числа в одной строке, начиная с первой. цифры отделяются пробелами.примерывходные данные123выходные
данные 1 2 3только через паскаль абс циклы for, while

Показать ответ
Ответ:
juliati88tan
juliati88tan
10.10.2020 03:54

var N,t,k,N1:integer;

BEGIN

readln(N);

N1:=N;

k:=0;

while (N1 mod 10=0) do begin

k:=k+1;

N1:=N1 div 10;

end;

t:=0;

while N>0 do begin

t:=t*10 + (N mod 10);

N:=N div 10;

end;

while t>0 do begin

write(t mod 10,' ');

t:=t div 10;

end;

for N:=1 to k do

write('0 ');

end.

0,0(0 оценок)
Ответ:
KeKoLolist
KeKoLolist
10.10.2020 03:54

program Digits;

procedure foo(a: integer);

begin

 if a = 0 then exit

 else

   foo(a div 10);

 Print(a mod 10)

end;

var

 a: integer;

begin

 a := 12345;

 foo(a)

end.


Напишите программу, которая выводит на экран все цифры числа, начиная с первой.входные данныевходная
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота