В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
notasmart
notasmart
20.01.2023 21:36 •  Информатика

Напишите программу которая заполняет элементы квадратной матрицы размером NxN лежащие нижи побочной диагонали значения -1, а остальные увеличиваются на 1. матрицу надо заполнить случайными числами в интервале [10,90]

Показать ответ
Ответ:
StacyZviozdohkina
StacyZviozdohkina
07.11.2020 09:36
Var c,i:integer;

function IntToBin2(Value: integer): string;
var  i: integer;
begin
Result:= '';
for i:= 0 to Trunc(Ln(Value)/Ln(2)) do
Result:= IntToStr((Value and (1 shl i) shr i))+Result;
end; 

begin;
for c:=41 to 69 do
writeln(c,'=',IntToBin2(c));
end.

Вывод:
41=101001
42=101010
43=101011
44=101100
45=101101
46=101110
47=101111
48=110000
49=110001
50=110010
51=110011
52=110100
53=110101
54=110110
55=110111
56=111000
57=111001
58=111010
59=111011
60=111100
61=111101
62=111110
63=111111
64=1000000
65=1000001
66=1000010
67=1000011
68=1000100
69=1000101
0,0(0 оценок)
Ответ:
gfitgfbjgffj
gfitgfbjgffj
20.03.2022 23:28
(начало)
|
/a,b,c/
| - +
< a>b and a>c > - /a/
| - + |
< b>c > /b/
| - |
/c/(konec)

(начало)
|
/a,b,c,d,e/
| - +
< a>b and a>c and a>d and a>e> - /a/
| - + |
< b>c and b>d and b>e > /b/
| - + |
< b>d and b>e > - /c/
| - + |
< d>e > /d/
| - |
/d/(konec)

(nachalo)
|
/a,b,c/
| +
< a=b and b=c >/'Wse starshe wseh'/
| - + + |
< a=b >< a > c >/'A u B starshe C'/
| | - |
| +/'C starshe wseh'/
| - + + |
< b=c >< b > a >/'B u C starshe A'/
| | - |
| +/'A starshe wseh'/
| - + + |
< a=c >< a > b >/'A u C starshe B'/
| | - |
| +/'B starshe wseh'/
| - + |
< a>b and a>c > /'A starshe wseh'/
| - + |
< b>c > /'B starshe wseh'/
| - |
/'C starshe wseh'/(konec)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота