Напишите программу которая заполняет массив случайными целыми положительными отрицательными или 0 числами и выводит их на экран Понятно и качественно!!
Программа: #include <iostream> using namespace std; int main() { int a=5; int b=4; int c; cout << "Количество яблок у Васи = " << a << "\n"; cout << "Количество яблок у Пети = " << b << "\n"; cout << "Количество яблок у Васи и Пети вместе = " << a+b << "\n"; c=(a+b)/3; cout << "Если разделить на 3-х поровну, то получится = " << c << "\n"; return 0; }
Результат: Количество яблок у Васи = 5 Количество яблок у Пети = 4 Количество яблок у Васи и Пети вместе = 9 Если разделить на 3-х поровну, то получится = 3
1. При использовании палитры из 2^24 цветов для хранения цвета 1 пикселя используется 24 бита = 3 байта. Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт. X = 8*(K*3/1024 + 128)+2.5*1024 2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта. Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт. X = 20*(K*2/1024 + 128) 8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128) К = 65536 (количество пикселей в рисунке) X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт = 20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт
#include <iostream>
using namespace std;
int main()
{
int a=5;
int b=4;
int c;
cout << "Количество яблок у Васи = " << a << "\n";
cout << "Количество яблок у Пети = " << b << "\n";
cout << "Количество яблок у Васи и Пети вместе = " << a+b << "\n";
c=(a+b)/3;
cout << "Если разделить на 3-х поровну, то получится = " << c << "\n";
return 0;
}
Результат:
Количество яблок у Васи = 5
Количество яблок у Пети = 4
Количество яблок у Васи и Пети вместе = 9
Если разделить на 3-х поровну, то получится = 3
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт =
20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт