В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
натали574
натали574
06.06.2021 01:13 •  Информатика

Напишите программу, которая заполняет массив случайными числами на отрезке [-2; 2] и считает сумму положительных элементов массива. (паскаль 9 класс)
типо этого

Показать ответ
Ответ:
vbbbbb
vbbbbb
15.02.2022 18:49

Var

N,A:integer;

Begin

Write('N = ');Read(N);

A:=0;

While N>0 do

  Begin

  if (N mod 10) > A then A:= N mod 10;

  N:=N div 10;

  End;

Write(A)

End.

Var

N,A,B:integer;

C:boolean;

Begin

Write('N = ');Read(N);

A:=-1;

B:=-2;

C:=false;

While N>0 do

  Begin

  if A=B then C:=true;

  if N>0 then

     Begin

     A:=N mod 10;

     N:=N div 10;

     End;

  if A=B then C:=true;

  if N>0 then

     Begin

     B:=N mod 10;

     N:=N div 10;

     End;

  End;

if A=B then C:=true;

if C then Write('Есть')

else Write('Нет')

End.

Подробнее - на -

0,0(0 оценок)
Ответ:
ееее70
ееее70
21.10.2021 20:22

ответ

4,0/5

2

SilverWind

   середнячок

   8 ответов

   2.6 тыс. пользователей, получивших

1. вывести на экран 6 раз своё имя

program imya;

const n=6;

var i:integer;

begin

for i:=1 to n do

writeln('ваше имя');

end.

Пояснения: делала с цикла (можно было написать и шесть раз writeln, но так удобнее). Переменную n ввела для быстрого изменения значений (если нужно будет написать имя не 6, а, к примеру, 8 раз, нужно было заменить только вначале). Ещё хочу отметить, что имя вводится по-английски и нельзя терять апострофы ( ' ).

2. program sum;

var sum:integer;

m:array[1..4] of integer;

i:integer;

begin

m[1]:=6

for i:=2 to 4 do begin

m[i]:=m[i-1]+1;

end;

sum:=m[1];

for i:=2 to 4 do begin

sum:=sum+m[i];

end;

writeln(sum);

end.

Пояснения: можно было делать и по-другому, но так тоже верно. Тут использовалось два цикла и массив. А блок-схему сами сделайте)))

3. program n!;

var n:real;

c:integer;

m:array[1..n] of integer;

begin

readln(n)

m[1]:=1;

for i:=2 to n do begin

m[i]:=m[i-1]+1;

end;

c:=m[1]

for i:=1 to n do begin

c:=c*m[i];

end;

writeln('n!',c);

end.

Если что не понятно, пишите, объясню

Объяснение:

сосиска

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота