В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
moonlight2812
moonlight2812
26.08.2021 15:38 •  Информатика

Напишите программу, которая запрашивает целое трёхзначное число и на экран выдаёт, сколько сотен содержится в данном числе.​

Показать ответ
Ответ:
wavesea
wavesea
19.08.2020 11:14
Можно конечно поизвращаться и придумать интересный алгоритм, но можно просто написать в лоб цикл с проверкой.

#include <iostream>
int main(){
    int num_1, num_2;
    cin >> num_1 >> num_2;
    for (int i = num_1 + 1; i != num_2; i++) {
        int cur = i, num = i;
        int res = 0;
        while (cur != 0) {
            int mod_n = cur % 10;
            if (mod_n == 0) {
                break;
            }
            if (num % mod_n == 0) {
                res = 1;
            }
            else {
                res = 0;
                break;
            }
            cur /= 10;
        }
        if (res) {
            cout << i << ' ';
        }
    }
}

Коротко, в двух словах, о чем тут код. 
мы проходим по циклу от A до B, для каждого числа, в цикле проверяем, делится ли оно на цифры из которых состоит. Для этого мы запоминаем в отдельную переменную cur наше число, и проверяем остаток от деления на 10 (т.е. самую левую цифру), после мы в cur записываем тоже число, но без последней цифры.
на примере 124. проверяем на делимость на 4, потом запоминаем 12, проверяем на делимость на 2, потом запоминаем 1, проверяем на делимость на 1, потом записываем 0. Как только видим 0 прекращаем. 
Дальше в цикле есть проверка на то, что если хоть раз что-то не поделилось, то переходим к след. числу
0,0(0 оценок)
Ответ:
мотя105
мотя105
01.01.2023 15:12

Файл (ағылш. File) — дерек сақтаудың негізгі бірлігі болып табылады.

Файл компьютердің бір дерек жинағын екіншісінен айыруына мүмкіндік береді. Мәтін жазылған немесе суреті бар кез келген қағаз құжат сияқты, файл дерек жинағы болып табылады, ондағы деректі бөліп алуға, өзгертуге, жоюға, сақтауға я болмаса басып шығарғыш немесе электрондық пошта бағдарламасы сияқты шығару құрылғысына жіберуге болады. Файлдардың ішінде бағдарлама, бағдарламада қолданылатын деректер немесе пайдаланушы жасаған құжат болуы мүмкін.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота