В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Arseniy2828
Arseniy2828
18.03.2022 09:50 •  Информатика

Напишите программу, которая запрашивает у пользователя два целых числа, а затем выводит их в виде предложение с использованием операторов деления (/) и модуля (%), например "Частное 25 и 3 равно

8 с остатком 1 ".
c# ​

Показать ответ
Ответ:
uldairuslanova
uldairuslanova
12.05.2023 02:49

function fibonacchi(x:integer):integer;

// функция возвращает порядковый номер введённого числа

// ряда Фибоначчи. Если число не является элементом

// из данного ряда, то функция возвращает -1

var counter:integer = 2;

   s1,s2,s3:integer;

begin

   s1 := 0;

   s2 := 1;

   s3 := 0;

   if x = 0 then fibonacchi:=1

   else if x = 1 then fibonacchi:=2

   else begin

       while s3 < x do begin

           s3 := s1 + s2;

           s1 := s2;

           s2 := s3;

           inc(counter);

       end;

       if s3 = x then fibonacchi:=counter

       else fibonacchi:=-1;

   end;

end;

begin

   write(fibonacchi(13));

end.

0,0(0 оценок)
Ответ:
aleksandrovauli
aleksandrovauli
12.03.2020 09:57

2-ое задание:

#include <iostream>

int main() {

int number;

std::cout << "Введите число: " << std::endl;

std::cin >> number;

if (number > 0)

 std::cout << "Положительное" <<std::endl;

else if (number < 0)

 std::cout << "Отрицательное" << std::endl;

else

 std::cout << "Ноль" << std::endl;

return 0;

}

1-ое задание:

#include <iostream>

int main() {

double dollars, grivnas;

std::cout << "Введите кол-во долларов: " << std::endl;

std::cin >> dollars;

grivnas = dollars * 28.3;

std::cout << dollars << " доллар-(а, ов) в гривнах " << grivnas << std::endl;

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота