В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
blablabla114
blablabla114
05.07.2020 06:38 •  Информатика

Напишите программу, которая запрашивает у пользователя координаты точки и затем рисует треугольник. В PascalABC

Показать ответ
Ответ:
latypova04
latypova04
09.06.2021 15:31

Const

    n = 12;

var

    i, p: integer;

    a: array[1..n] of integer;

begin

    p := 1;

    for i := 1 to n do

    begin

        a[i] := random(150) - 100;

        write(a[i], ' ');

        if a[i] > 0 then p := p * a[i];

    end;

    writeln;

    writeln('P = ', p);

end.

2)uses crt;

var a:array [1..10] of integer;

i:integer;

begin

clrscr;

randomize;

{генерируем и выводим новый массив}

for i:=1 to 10 do

begin

a[i]:=random(9)+1;

write(a[i]:3);

end;

writeln;

{в цикле проверяем если счетчик i делится на 2 ( признак четности) то либо возводим в степень либо удваиваем}

for i:=1 to 10 do

begin

if (i mod 2=0 ) then a[i]:=a[i]*a[i]

else a[i]:=a[i]*2;

end;

{выводим конечный массив}

for i:=1 to 10 do

write(a[i]:3);

readkey;

end.

3)var arr:array[1..20] of integer;

max,q:integer;

begin

writeln ('ARRAY: ');

for q:=1 to 20 do

begin

arr[q]:=random(80);

write (arr[q]:3);

end;

max:=arr[1];

for q:=2 to 20 do

if arr[q]>max then max:=arr[q];

writeln;

writeln('MAX = ',max);

end.

0,0(0 оценок)
Ответ:
bobamina2004
bobamina2004
02.11.2022 20:18

1. Например : Домашняя работа , бизнес план

2. Сообщите учителю или своим родителям, чтобы они связались с человеком который скопировал у вас работу

3.  Присвоение авторства (плагиат), если это деяние причинило крупный ущерб автору или иному правообладателю, -

наказывается штрафом в размере до двухсот тысяч рублей или в размере заработной платы или иного дохода осужденного за период до восемнадцати месяцев, либо обязательными работами на срок до четырехсот восьмидесяти часов, либо исправительными работами на срок до одного года, либо арестом на срок до шести месяцев.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота