В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
кириешка5
кириешка5
21.05.2023 03:36 •  Информатика

Напишите программу на Pascal: Напишите среднее значение целых положительных чисел, которые вводятся с клавиатуры (окончание ввода-ввод числа 0)

Показать ответ
Ответ:
narenkovaa
narenkovaa
15.10.2020 05:01

//Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

ТАК) (Я НЕСОВСЕМ УВЕРЕН)

0,0(0 оценок)
Ответ:
PodolskayaOlli
PodolskayaOlli
15.10.2020 05:01

--- PascalABC.NET 3.6.2 ---

begin

 ReadSeqIntegerWhile(p -> p <> 0).Where(p -> p > 0).Average.Println;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота