В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Sania24sania
Sania24sania
06.12.2021 10:35 •  Информатика

Напишите программу на pascal. нужно ввести число (любое) и должно выдавать, что оно больше, меньше или равно 10-ти. притом, что должно быть две строчки с if, а не три.

Показать ответ
Ответ:
Ольга1738
Ольга1738
09.10.2020 07:51
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var x := ReadReal;

 if x < 10 then Print('Число меньше 10')

 else

   if x = 10 then Print('Число равно 10')

   else Print('Число больше 10')

end.

0,0(0 оценок)
Ответ:
Lasnochas
Lasnochas
09.10.2020 07:51

Program AddNums(output);

var x:integer;

begin

   readln(x);

 

   x:=x-10;

   

   if x<>0 then

   if x>0 then

     writeln('bolshe 10')

   else writeln('menshe 10')

 

   else writeln('ravno 10')

   

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота