В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
edeeeeeeffer
edeeeeeeffer
27.07.2020 05:09 •  Информатика

Напишите программу на pascalabc, которая решает это математическое выражение .


Напишите программу на pascalabc, которая решает это математическое выражение .

Показать ответ
Ответ:
Ира0386
Ира0386
08.10.2020 23:17

Объяснение:

a := 30

b := 6

a := a * 3 / b

если a < b

то c := 2 * a – 5 * (b + 2)

иначе c := 2 * a + 5 * (b + 2)

все

2) a := 30

b := 18

a := 3 * b - a

если a > b

то с := 2 * a - b

иначе c := 2 * a + b

все

3) a := 56

b := 7

k := 6

a := a/7 - b

если a > b

то c := a - k*b

иначе c := a + k*b

все

4) алг

нач

цел s, t

ввод s

ввод t

если s > 8 и t > 8

то вывод "YES"

иначе вывод "NO"

все

кон

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(9, 10); (11, 5); (–2, 8); (9, 9); (2, 8); (–1, 3); (–4, 5); (10, 9); (4, –3).

Сколько было запусков, при которых программа напечатала «YES»?

5) алг

нач

цел s, t

ввод s

ввод t

если s > 4 и t > 4

то вывод "YES"

иначе вывод "NO"

все

кон

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(10, 6); (7, 6); (–4, 3); (2, 9); (12, 7); (–11, 4); (–8, 13); (10, 9); (6, 5).

Сколько было запусков, при которых программа напечатала «NO»?

6) алг

нач

цел s, t

ввод s

ввод t

если s > 6 и t < 7

то вывод "YES"

иначе вывод "NO"

все

кон

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(7, 3); (2, 7); (6, 10); (5, 3); (5, 4); (–11, 4); (–8, 9); (7, 3); (9, 1).

Сколько было запусков, при которых программа напечатала «YES»?

7) алг

нач

цел s, t

ввод s

ввод t

если s > 2 и t < 5

то вывод "YES"

иначе вывод "NO"

все

кон

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(–2, 3); (2, 5); (0, 3); (5, –3); (5, 4); (11, 4); (8, –6); (7, 3); (9, 1).

Сколько было запусков, при которых программа напечатала «YES»?

0,0(0 оценок)
Ответ:
Oneganin
Oneganin
13.04.2022 16:35

import math as m

def Perimeter():

   x1 = int(input("x1 = "))

   y1 = int(input("y1 = "))

   x2 = int(input("x2 = "))

   y2 = int(input("y2 = "))

   x3 = int(input("x3 = "))

   y3 = int(input("y3 = "))

   print("A({};{})\tB({};{})\tC({};{})".format(x1,y1,x2,y2,x3,y3))

   """ √ ((X ₂-X ₁) ² + (Y ₂-Y ₁) ²) +  

   √ ((X ₃-X ₂) ² + (Y ₃ — Y ₂) ²) +  

   √ ((X ₃-X ₁) ² + (Y ₃-Y ₁) ²). """

   p = m.sqrt((x2 - x1) ** 2 + (y2 - y1) ** 2) + m.sqrt((x3 - x2) ** 2 + (y3 - y2) ** 2) + m.sqrt(

       (x3 - x1) ** 2 + (y3 - y1) ** 2)

   print('Периметр: P = {}.'.format(p))

   print('Полупериметр: p = {}.'.format(p/2))

Perimeter()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота