В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vikazelenaya1
vikazelenaya1
29.08.2021 04:19 •  Информатика

Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном расстоянии l на высоте h над уровнем горизонта при заданном угле d и начальной скорости v0.в ответе должен высчитаться угол и написать программа "попал" ты или нет

Показать ответ
Ответ:
vanyazoro
vanyazoro
05.10.2020 13:31

Чтобы наш снаряд (пуля, мяч или что-то еще) попало в цель, нужно чтобы высота подъема снаряда совпала с высотой, на которой расположена цель, и чтобы дальность полета совпала с заданным расстоянием. Иначе снаряд может улететь выше или ниже цели или не долетать.

Воспользуемся формулами по равнозамедленному движению.


program zadacha;

const

g=9.8;

var

h,L,a,V,S,h1:real;

begin

writeln('vvedite visotu i dalnost celi');

readln(h,L);

writeln('vvedite ugol, skorost snariada');

readln(a,V);

a:=a*pi/180;

h1:=int(( sqr(V)* sqr(sin(a))) / (2*g));

S:=int((sqr(V)*sin(2*a))/g);

if (S=L) and (h1=h) then writeln('popal') else writeln('ne popal');

end.


Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном р
Напишите программу на паскале,которая будет сообщать можно ли попасть в цель находящая на заданном р
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота