В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу НА ПАСКАЛЕ, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными. в ОТВЕТЕ ИСПОЛЬЗУЙТЕ repeat и until
Пример:
Введите два числа:
10 -15
10*(-15)=-150

Показать ответ
Ответ:
Синтол
Синтол
22.10.2022 00:07
#include <iostream>#include <stdlib.h>#include <locale.h>using namespace std;
void main(){ setlocale(0, ""); int a = 100, num, player = 1, correct; while (a > 0) { if (player == 1) { do { cout << "Ваш ход. На столе " << a <<" спичек" << endl; cout << "Сколько спичек вы берете?" << endl; cin >> num; if ((num > 0) && (num <= 10)) { correct = true; } } while (correct != true); } else { if ((a <= 10) && (a > 1)) { num = a - 1; } else if (a == 1) { num = 1; } else { if (num > a) { num = a; } } cout << "Компьютер взял " << num << " спичек" << endl; } a = a - num; if (player == 1) { player = 2; } else { player = 1; } } if (player == 1) { cout << "Вы проиграли" << endl; } else cout << "Вы победили" << endl; system("pause");}
0,0(0 оценок)
Ответ:
ykim1337
ykim1337
22.01.2020 07:07
Описание алгоритма:
Пусть даны числа a, b, c, d. Сравниваем a и b, c и d. Затем сравниваем максимальные числа в своих парах (наибольшее из них - максимальное среди всех чисел) и минимальные числа в своих парах (наименьшее из них - минимальное среди всех чисел). Сравниваем оставшиеся два числа и получаем информацию о порядке всех чисел, которую выводим на экран.

Реализация (python 3)
a, b, c, d = map(int, input().split())
if a > b:
    a, b = b, a
if c > d:
    c, d = d, c
if a > c:
    a, c = c, a
if b > d:
    b, d = d, b
if b > c:
    b, c = c, b
print(a, b, c, d)

Пример ввода:
1 4 2 3
Пример вывода:
1 2 3 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота