В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
anastasiagarap
anastasiagarap
26.04.2020 01:59 •  Информатика

Напишите программу на паскале, которая выбирает из списка футболистов лучшего бомбардира – того, кто забил наибольшее количество мячей. если несколько человек забили одинаковое наибольшее количество мячей, нужно вывести их имена и фамилии в том порядке, в котором они встречаются в исходном списке. входные данные в первой строке записано количество футболистов в списке n . следующие n строк имеют формат: < фамилия> < имя> < год рождения> < число забитых мячей> выходные данные программа должна вывести фамилии и имена тех футболистов, которые забили наибольшее количество мячей. в последней строке программа выводит количество голов, забитых каждым из этих футболистов.

Показать ответ
Ответ:
NadyaSmirnovaa
NadyaSmirnovaa
21.08.2022 15:29
Const n=15; 
var a:array[1..n] of integer;
i,s:integer; sr:real;
begin
Randomize;
writeln('Массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:3);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
sr:=s/n;
writeln('Среднее арифметическое = ',sr:6:2);
writeln('Номера элементов, больших среднего арифметического:');
for i:=1 to n do
 if a[i]>sr then write(i:3);
writeln;
end.

Пример:
Массив:
  9 19 14 8 7 10 5 10 6 14 15 2 11 17 13
Среднее арифметическое = 10.67
Номера элементов, больших среднего арифметического:
  2 3 10 11 13 14 15
0,0(0 оценок)
Ответ:
pipinkorotkiy1
pipinkorotkiy1
16.05.2022 16:09
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),1,99);
  a.Println;
  var k:=ReadInteger('k=');
  Writeln('Сумма чисел, кратных ',k,': ',
    a.Where(x->x mod k=0).Sum)
end.

Тестовое решение:
n= 18
45 17 36 15 65 17 97 44 49 43 60 51 66 72 18 55 71 85
k= 12
Сумма чисел, кратных 12: 168

// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),1,20);
  a.Println;
  a.Where((x,i)->x=i+1).Println
end.

Тестовое решение:
n= 16
17 2 1 14 20 19 10 3 9 15 14 4 2 7 2 16
2 9 16
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота