В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
лим0н
лим0н
27.02.2021 13:55 •  Информатика

Напишите программу на паскале: три точки заданы своими координатами на плоскости, определить минимальный радиус окружности охватывающий все эти точки ( центр в начале координат, минимальный радиус считается по самой удолённой точке, соответственно окружность должна лежать на нёй)

Показать ответ
Ответ:
kriss6745
kriss6745
09.10.2020 21:40

uses math;

var x1, x2, x3, y1, y2, y3: real;

begin

read(x1, y1, x2, y2, x3, y3);

writeln(max(max(sqrt(x1 * x1 + y1 * y1), sqrt(x2 * x2 + y2 * y2)), sqrt(x3 * x3 + y3 * y3)));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота