Напишите программу на паскале: Вывести фигуру треугольника из чисел от 1 до 15 с “вертикальной разверткой”, т.е. в первом столбике будут числа от 1 до 5, во втором от 6 до 9 и в последнем 15. И используйте цикл, чтобы программа была короче.
От эффективности алгоритмов управления локальными ресурсами компьютера во многом зависит эффективность всей сетевой ОС в целом. Поэтому, характеризуя сетевую ОС, часто приводят важнейшие особенности реализации функций ОС по управлению процессорами, памятью, внешними устройствами автономного компьютера. Так, например, в зависимости от особенностей использованного алгоритма управления процессором операционные системы делят на многозадачные и однозадачные, многопользовательские и однопользовательские, на системы, поддерживающие многонитевую обработку и не поддерживающие ее, на многопроцессорные и однопроцессорные системы.
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
char ch;
cin >> ch;
if ((ch >= 'A' && ch <= 'Z') || (ch >= 'a' && ch <= 'z'))
{
if (ch == 'a' || ch == 'A' ||
ch == 'e' || ch == 'E' ||
ch == 'u' || ch == 'U' ||
ch == 'O' || ch == 'o' ||
ch == 'I' || ch == 'i')
cout << ch << "-" << "гласная " << endl;
else cout << ch << "-"<< "согласная ";
}
cin.get();
cin.get();
return (0);
}
От эффективности алгоритмов управления локальными ресурсами компьютера во многом зависит эффективность всей сетевой ОС в целом. Поэтому, характеризуя сетевую ОС, часто приводят важнейшие особенности реализации функций ОС по управлению процессорами, памятью, внешними устройствами автономного компьютера. Так, например, в зависимости от особенностей использованного алгоритма управления процессором операционные системы делят на многозадачные и однозадачные, многопользовательские и однопользовательские, на системы, поддерживающие многонитевую обработку и не поддерживающие ее, на многопроцессорные и однопроцессорные системы.
Объяснение:
однозадачные (например, MS DOS, MSX);
многозадачные (ОС ЕС, OS/2, UNIX, Windows).