Напишите программу на perl, которая из одного текстового файла, в котором содержится следующая информация : фамилия, имя, отчество, в другой скопировала бы строки таким образом, чтобы во втором файле содержалось - фамилия и инициалы.
Const Pi=3.1415926598; var c:integer; r,a,b,h:real; begin Writeln('Введите код вычисляемой величины: '); Writeln('1 - длина окружности'); Writeln('2 - площадь круга'); Writeln('3 - объем цилиндра'); Writeln('4 - объем параллелепипеда'); Write('-> '); Read(c); case c of 1: begin Write('Введите радиус окружности: '); Read(r); Writeln('Длина окружности равна ',2*Pi*r) end; 2: begin Write('Введите радиус круга: '); Read(r); Writeln('Площадь круга равна ',Pi*r*r) end; 3: begin Write('Введите радиус и высоту цилиндра: '); Read(r,h); Writeln('Объем цилиндра равен ',Pi*r*r*h) end; 4: begin Write('Введите длину, ширину и высоту параллелепипеда: '); Read(a,b,h); Writeln('Объем параллелепипеда равен ',a*b*h) end end end.
Пример работы Введите код вычисляемой величины: 1 - длина окружности 2 - площадь круга 3 - объем цилиндра 4 - объем параллелепипеда -> 3 Введите радиус и высоту цилиндра: 5 18.3 Объем цилиндра равен 1437.2786418585
Pi=3.1415926598;
var
c:integer;
r,a,b,h:real;
begin
Writeln('Введите код вычисляемой величины: ');
Writeln('1 - длина окружности');
Writeln('2 - площадь круга');
Writeln('3 - объем цилиндра');
Writeln('4 - объем параллелепипеда');
Write('-> '); Read(c);
case c of
1: begin
Write('Введите радиус окружности: '); Read(r);
Writeln('Длина окружности равна ',2*Pi*r)
end;
2: begin
Write('Введите радиус круга: '); Read(r);
Writeln('Площадь круга равна ',Pi*r*r)
end;
3: begin
Write('Введите радиус и высоту цилиндра: '); Read(r,h);
Writeln('Объем цилиндра равен ',Pi*r*r*h)
end;
4: begin
Write('Введите длину, ширину и высоту параллелепипеда: '); Read(a,b,h);
Writeln('Объем параллелепипеда равен ',a*b*h)
end
end
end.
Пример работы
Введите код вычисляемой величины:
1 - длина окружности
2 - площадь круга
3 - объем цилиндра
4 - объем параллелепипеда
-> 3
Введите радиус и высоту цилиндра: 5 18.3
Объем цилиндра равен 1437.2786418585
задача 1
поскольку и объем лазерного диска и объем дискеты выражены в одних единицах, можно сразу приступать к вычислениям
разделим объем лазерного диска на объем дискеты
650/1,39=467,6 (приблизительно 468) дискет
задача2а
переведем килобайты в байты, умножив на 1024
5Кб=5*1024=5120 байт переведем байты в биты, умножив на 8
5120 байт*8=40960 бит
задача2б
чтобы перевести биты в байты разделим их на 8
12288бит/8=1536 байт
чтобы перевести байты в килобайты разделим полученное число на 1024
1536/1024=1,5 Кб
задача2в
переведем биты в байты
2^13/2^3=2^10 при делении показатели степеней вычитаются
переведем байты в килобайты
2^10/2^10=1Кб