Напишите программу на питоне Каждая бактерия делится на две в течение 1 минуты. В начальный момент имеется одна бактерия. Составьте программу вычисления количества бактерий через 60 минут.
var a, b, c, d, i, j :integer; s :array [1..100,1..100] of integer; begin b:=63999; c:=-63999; for i:=1 to 15 do begin writeln; for j:=1 to 15 do begin s[i,j]:=random(127998)-63999; a:=a+s[i,j]; if s[i,j]>c then c:=s[i,j]; if s[i,j]<b then b:=s[i,j]; write (s[i,j],' '); end; end; writeln; writeln ('Сумма элементов = ', a); writeln ('Максимальный элемент = ', c); writeln ('Минимальный элемент = ', b); end.
Устройство для передачи и приёма звука (в основном — человеческой речи) на расстоянии. Современные телефоны осуществляют передачу посредством электрических сигналовВ целом, телефон — это устройство передавать звук на большое расстояние. Самые первые телефоны были механическими приборами с прямым акустическим каналом, т.е. их принцип действия основывался на распространении звуковых колебаний в сплошных средах (воздух и др.), в отличие от современных электрических приборов, использующих электромагнитные сигналы.Согласно письму в «Peking Gazette», в 968 году китайский изобретатель Кунг-фу-винг создал thumtsein, который, вероятно, передавал звук через трубы. Разговоры через трубы используются и сегодня при передаче звука на небольшие расстояния между фиксированными точками (на судах, предприятиях и т. д.).«Верёвочный телефон» также известен много веков. В нём две мембраны соединялись бечёвкой или проволокой..Общее несовершенство акустических телефонов в том, что через относительно небольшое расстояние (примерно десять километров) звуковые колебания сильно затухают, в результате чего передача сигнала неэлектрическим путём на большие расстояния без промежуточных пунктов невозможна.
s :array [1..100,1..100] of integer;
begin
b:=63999;
c:=-63999;
for i:=1 to 15 do
begin
writeln;
for j:=1 to 15 do
begin
s[i,j]:=random(127998)-63999;
a:=a+s[i,j];
if s[i,j]>c then c:=s[i,j];
if s[i,j]<b then b:=s[i,j];
write (s[i,j],' ');
end;
end;
writeln;
writeln ('Сумма элементов = ', a);
writeln ('Максимальный элемент = ', c);
writeln ('Минимальный элемент = ', b);
end.