В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
almagul82
almagul82
16.04.2023 17:11 •  Информатика

Напишите программу на питоне , которая сначала считывает три фразы по очереди, а потом воспроизводит их в той же последовательности, каждую на отдельной строчке.

Показать ответ
Ответ:
Roman07156
Roman07156
14.11.2021 09:05

ответ:A№1

mass = [int(input()) for i in range(5)]

for i in mass:

   if i % 3 == 0 and i % 10 == 8:

       print(i, end=' ')

№2

from random import randint

mass = [randint(100, 999) for i in range(100, 1000)]

for i in range(len(mass) - 1):

   for j in range(i + 1, len(mass)):

       if mass[i] % 100 > mass[j] % 100:

           mass[i], mass[j] = mass[j], mass[i]

print(mass)

№3

from random import randint

mass = [randint(0, 1000) for i in range(1000)]

for i in range(len(mass) - 1):

   if mass[i] == mass[-1]:

       print(i, end=' ')

B№1

mass = [int(input()) for i in range(5)]

k = 0

for i in mass:

   if str(i)[0] == '8':

       k += 1

print(k)

№2

from random import randint

mass = [randint(100, 999) for i in range(100, 1000)]

for i in range(len(mass) - 1):

   for j in range(i + 1, len(mass)):

       if sum(map(int, str(mass[j]))) < sum(map(int, str(mass[i]))):

           mass[i], mass[j] = mass[j], mass[i]

print(mass)

№3

from random import randint

mass = [randint(0, 1000) for i in range(1000)]

print(mass)

k = mx = 0

for i in range(1, len(mass)):

   if mass[i] * mass[k] > mx:

       mx = mass[i] * mass[k]

       max_i, max_k = i, k

   k += 1

print(max_k, max_i)

Объяснение:

не знаю сколько чисел должно быть в массиве в интервале от 0, 1000

если надо изменить, то поменять в range(1000) на нужное кол-во чисел

0,0(0 оценок)
Ответ:
1аук7
1аук7
25.10.2022 12:35
Делаем всё по уму.
1. Два столбца и три рядка размечаем.
— Столбцы: "Год", "Месяц"
— Ряды: "День рождения", "Текущая дата", "Возраст"
2. "День рождения" заполняем вручную, указываем в столбце "Год" - год рождения, в столбце "Месяц" - месяц рождения.
3. Заполняем по формулам текущую дату в ряде "Текущая дата", формула для столбца "Год":
— "=YEAR(TODAY())", функция TODAY() - возращает текущую дату в формате Exel, функция YEAR() - принемает дату формата Exel и возращает год в виде целого числа.
— "=MONTH(TODAY())", работает схоже с предыдущей функцией, но в отличии от нее, определяет из текущей даты - месяц.
4. Заполняем ряд "Возраст", тут указываем формулы для столбца "Год" и "Месяц" простые формулы, где вычетаем из текущей даты - дату рождения.

Превью на картинке и Exel документ с ним же.
Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь—
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота