В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
volck223
volck223
26.11.2021 08:25 •  Информатика

Напишите программу на Питоне: Программа из различных занятий пассажира выберет благопристойные, то есть те, что с проверочной фразой имеют более 7 общих слов. Вводится проверочная фраза, а затем строка занятий через точку с запятой и пробел. Через @ окружённый пробелами вывести только те занятия которые с проверочной фразой имеют более 7 общих символов. Одинаковые символы считать за один, регистр важен.

Показать ответ
Ответ:
Музалевская
Музалевская
11.01.2022 20:32
Function prime(x:integer):boolean;
var
 t:boolean;
 d:integer;
begin
 t := true;
 d := 2;
 while t and (d*d <= x) do
   begin
   if x mod d = 0 then 
     t := false;
   d := d + 1
   end;
 prime := t
end;

function order(x:integer):boolean;
var
 t:boolean;
 d:integer;
begin
 d := -1;
 repeat
   t := x mod 10 > d;
   d := x mod 10;
   x := x div 10
 until not t or (x = 0);
 order := t
end;

var
 t:boolean;
 i,k,n:integer;
begin
 t := false;
 read(k,n);
 for i := k to n do
   if prime(i) then
   if order(i) then
     begin
     write(i,' ');
     t := true
     end;
 if not t then
   write(0)
end.
0,0(0 оценок)
Ответ:
Anastasya156
Anastasya156
06.09.2020 15:10

Вот, нашел на одном из сайтов: #include <iostream>

#include <conio.h>

#include <cstdlib>

#include <ctime>

using namespace std;

int main (){

   srand(time(0));

   int n, one, two, co=0, ol, k=0, var, sum1=0, sum2=0;

   bool kto=true;

   cout << "Privet davaii sigraem v kosti.\nPobedit tot u kogo suma 3 broskov budet bolshe\n\n";

   while (k<3)

   {

       cout << "\n1 - Brositj kubik\n2 - Vijti\nViberi variant: ";

       cin >> var;

       if (var==1)

       {

           for (int j=0; j<=1; j++)

               {

                   one=1+(rand()%6);

                   two=1+(rand()%6);

                   cout << "\n";

                   if (kto) cout << "\tTvoi kubiki\n";

                   if (!kto) cout << "\tMoi kubiki\n";

                   cout << "\n";

                   for (int i=1; i<=5; i++)

                   {

                           if (i==1) n=1;

                           else if (i==2 && one==1) n=2;

                           else if (i==2 && one==3 || i==2 && one==2) n=3;

                           else if (i==2 && one==4 || i==2 && one==5 || i==2 && one==6) n=4;

                           else if (i==3 && one==3 || i==3 && one==1 || i==3 && one==5) n=5;

                           else if (i==3 && one==2 || i==3 && one==4) n=2;

                           else if (i==3 && one==6) n=4;

                           else if (i==4 && one==1) n=2;

                           else if (i==4 && one==3 || i==4 && one==2) n=6;

                           else if (i==4 && one==4 || i==4 && one==5 || i==4 && one==6) n=4;

                           else if (i==5) n=7;

                       switch (n){

                           case 1:

                           cout << (char)201 << (char)205  << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)187;

                           break;

                           case 2:

                           cout << (char)186 << "       " << (char)186;

                           break;

                           case 3:

                           cout << (char)186 << " o     " << (char)186;

                           break;

                           case 4:

                           cout << (char)186 << " o   o " << (char)186;

                           break;

                           case 5:

                           cout << (char)186 << "   o   " << (char)186;

                           break;

                           case 6:

                           cout << (char)186 << "     o " << (char)186;

                           break;

                           case 7:

                           cout << (char)200 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)188;

                           break;

                       }

                       if (co%2==0) {

                           cout << "\t";

                           i--;

                           ol=one;

                           one=two;}

                       else {

                           cout << endl;

                           one=ol; }

                   co++;

                   }

                   if (kto){

                       sum1=sum1+one+two;

                       kto=false;

                       continue;

                   }

                   if(!kto){

                       sum2=sum2+one+two;

                       kto=true;

                   }

               }

           }

           else if (var==2) return 0;

           else {

               cout << "\n!!! Viberi variant 1 ili 2 !!!\n";

               continue;}

               k++;

   }

   cout << "\nTvoj rezultat = " << sum1 << endl << "Moj rezultat = " << sum2 << endl;

   if (sum1>sum2)

       cout << "\n\tTi pobedil ;)";

   else cout << "\n\tTi proigral :(";

   getch ();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота