В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
оkсана06
оkсана06
24.07.2020 06:34 •  Информатика

Напишите программу на питоне .

в первой строке выведите число n – количество тестов (1 ≤ n ≤ 10).

в каждой из следующих строк должно содержаться число k (1 ≤ k ≤ 1000) количество чисел, которое необходимо отсортировать. затем должны следовать k целых чисел, каждое из которых по модулю не превосходит 1.

Показать ответ
Ответ:
ЕгорВанШот
ЕгорВанШот
10.04.2023 16:50
1. PascalABC.NET 3.2

begin
  var s:=ReadlnString('Введите натуральное число:');
  var c:=ReadlnChar('Введите цифру для поиска:');
  if Pos(c,s)>0 then Writeln('Такая цифра есть')
  else Writeln('Такой цифры нет')
end.

2. PascalABC.NET любой версии, Free Pascal и т.д. на строках

var
  s:string;
  c:char;
begin
  Write('Введите натуральное число: '); Readln(s);
  Write('Введите цифру для поиска: '); Readln(c);
  if Pos(c,s)>0 then Writeln('Такая цифра есть')
  else Writeln('Такой цифры нет')
end.

3. То же, но без строк, с циклом

var
  n:longint;
  d:0..9;
begin
  Write('Введите натуральное число: '); Read(n);
  Write('Введите цифру для поиска: '); Read(d);
  while n>0 do begin
    if n mod 10=d then begin
      Writeln('Такая цифра есть');
      Exit
      end;
    n:=n div 10
    end;
  Writeln('Такой цифры нет')
end.
0,0(0 оценок)
Ответ:
karamnovagmai
karamnovagmai
10.04.2023 16:50
//PascalABC.NET 3.2 сборка 1318

Var
  n,a:integer;
  b:boolean;
begin
b:=true;      //"флаг", указывающий на результат
readln(a);    //вводим цифру
readln(n);    //вводим число
while n>0 do          //пока число не равно 0 
if n mod 10=a then  //mod 10 возвращает последнюю цифру числа   
begin
      b:=false;       //если эта цифра равна а, тогда "флаг" меняет своё значение
      break;          //и выходим из цикла
    end
  else
      n:=n div 10;    {иначе посредством div 10 убираем самый правый разряд. Если левый аргумент меньше 10, он вернёт 0 и тем самым завершит цикл}
if b=true then writeln('Да') else writeln('Нет'); {"флаг" остаётся true только если не встретилось совпадений в цикле}
end.      

Пример ввода:
3
123
Пример вывода:
Нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота