В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ника11082001
ника11082001
03.05.2020 03:31 •  Информатика

Напишите программу на Python для следующей задачи: "Среди четырехзначных чисел выбрать те, у которых все четыре цифры различны. "

Показать ответ
Ответ:
аноним56889
аноним56889
09.03.2021 20:50

Объяснение:

n = int(input()) - #сколько чисел

for i in range(n):

   a = int(input()) #вводим числа

   if a %10 != a//10%10 and a %10 != a//100 and a //10 %10 != a//100:  #проверяем чила

       print('Yes')

   else:

       print('No')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота