В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
znaniacom945
znaniacom945
24.11.2020 03:43 •  Информатика

Напишите программу на Python, которая бы вычисляла нумерологическое число (складываются числа даты рождения, до тех пор, пока не получится число от 1 до 9, допустим 23.01.2001 = 2 + 3 + 0 + 1 + 2 + 0 + 0 + 3 = 11 = 1 + 1 = 2. Нумерологическое число = 2.

Показать ответ
Ответ:
lawrence02
lawrence02
15.07.2021 00:35

date=input()

numb=0

while not 0<numb<10:

   numb=0

   for i in date:

       if i.isdigit():

           numb+=int(i)

   date=str(numb)

print(numb)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота