В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
MrGromFull
MrGromFull
12.05.2020 22:54 •  Информатика

Напишите программу на Python, которая ищет среди целых чисел, принадлежащих числовому отрезку [1024; 28921], числа, которые делятся на сумму всех своих цифр. Запишите в ответе сумму всех таких чисел. Например, в диапазоне [12; 20] есть следующие числа: 12,18,20. Поэтому
для этого диапазона ответом является 12+18+20=50.

Показать ответ
Ответ:
саша3421342
саша3421342
18.07.2021 19:00

def delitel(n):

   summa=0

   while n:

       summa+=n%10

       n//=10

   return summa

summa=0

for i in range(1024,28922):

   if i%delitel(i)==0:

       summa+=i

print(summa)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота