В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Pisos1337228
Pisos1337228
21.08.2022 06:59 •  Информатика

Напишите программу на python, которая вычисляет средний рост учеников. Алгоритм должен в цикле пользователя ввести рост ученика. Цикл завершается, когда пользователь введет рост, равный нулю. Программа должна вывести средний рост учеников в классе.

Формат ввода
Вводятся целые числа одно за другим, на отдельных строках.

Формат вывода
Выводтся одно значение среднего роста

Показать ответ
Ответ:
Вика250411
Вика250411
12.10.2020 22:47

n=0

s=0

a=1

while a!=0:

   a=int(input())

   n+=1

   s+=a

print(s/(n-1))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота